Common Problem?

It seems to be a common problem with Ducato’s that the fuel gauge either intermittently stops working, or fails completely. There are a couple of common causes for this (note: this is for a 1999 Ducato 2.8idtd. much earlier or later vans are likely to be different):-

The first and easiest to check is the module that controls the gauge in the dash, this module is located behind the dash underneath the glove box and if you use the cup holders in the glove box lid spillages can run off the lid and get into the module/connector, causing all sorts of weird electrical gremlins.

To investigate the module the first job is to remove the lower dash panel (the one that holds the speaker) – here is a picture of it removed on our bus (ours is a left hand drive but I believe the right hand drive vans are just a mirror image of this):-

The module you are looking for is the one circled in red below:-

If you unplug the connector you will be able to see if anything has got into the connector, and a spray of electrical contact cleaner should sort it out if it has. You can also remove the module completely and take the board out to see if anything has got into the housing itself. Again, electrical contact cleaner can be used to clean up the board if necessary.

Here is a photo of the board once removed from the module:-

Another area that can cause problems is if water etc. gets into the electrical connector on the fuel sender on top of the fuel tank. Fortunately this is also easy to get at to check. In the dash floor you will find this panel circled in red below:-

With that panel removed and another one in the floor below it removed you will be able to see the fuel and electrical connections on the top of the fuel tank:-

This area is exposed underneath the van and as you can see quite a lot of crap gets on it over the years!

The electrical connector for the fuel level sender is the one at the top of the photo below. It is a sealed connector but worth checking/cleaning anyway if you have issues with the gauge:-

Cleaning these two areas sorted all the problems on our bus. If you are still having problems after this point it is probably an issue with the fuel level sensor itself in the tank – to check/replace this you will need to remove the two fuel lines from the clips in the photo above, then undo the six hex nuts on the circular plate to lift the whole unit out of the tank.

Note – if you have a later common rail engine you may have an electrical lift pump in the tank, in which case there will also be wiring for this going to the tank unit.

Hope this helps, if you have any questions/comments or know of any other common issues/fixes please let me know below!